3d en OpenSuse 10.3, Linux en mi laptop Toshiba Satellite A215

Como lo comenté en este post, instalé Linux en mi laptop recientemente, pero el problema que me quedó pendiente fue el 3D. Casi inmediatamente, Carlos Rocha contestó en este blog con lo siguiente:

Que tal como estas, solo para comentarte que acabo de instalar el opensuse hoy en el mismo modelo de laptop, yo instale el driver que viene el la pagina de amd, y me funciono y aunque cuando echo a andar el panel de control de ati me dice que no tiene soporte para aceleracion 3d por hardware, le instale el xgl y el compiz y funciono de maravilla, todavia estoy en proceso de instalacion de drivers y afinacion de ciertos detallitos, que espero que queden en el transcurso de la semana…
Los drivers los puedes descargar de la pagina http://ati.amd.com/support/driver.html ,
en el sistema operativo seleccionas linux_64 >> Integrated/Motherboard >> RAdeon Xpress 1250..
este es un archivo .run, lo instalas desde el suse, y ejecutas el comando aticonfig –initial, reinicias y listo..
Espero te haya sido de ayuda.
saludos.

Pues bien, hice esto, desinstalé previamente el controlador fgl que ya tenía antes que nada, y siguiendo las instrucciones de la página Wiki de OpenSuSE para instalar este controlador, conseguí mi 3D!!!! Pueden ver la captura de pantalla en http://invernalia.homelinux.net/~jstitch/jstitch/linux/snapshot1.png.

Muchísimas gracias!

snapshot1.png

Anuncios

8 Responses to “3d en OpenSuse 10.3, Linux en mi laptop Toshiba Satellite A215”


  1. 1 Sebastian abril 16, 2008 en 9:44

    Hola Javier, te escribo desde Argentina. Segui tus posts, tengo openSUSE 10.3 en una A215-S7428 (casi mismo hard que tu laptop). No he podido con el sonido, baje el paquete pero no me reconocio la placa.
    Lo extraño que si lo hizo el YaST2 luego de ejecutar el script ./install. ¿me podrias enviar a mi correo o aqui en un post tu archivo
    /etc/modprobe.d/sound?
    (yo lo modifique y creo que hice mal algo)
    Saludos
    Sebastian

  2. 2 sebastian abril 16, 2008 en 17:18

    Hola Javier y gente visitante del blog! este post es para decirles que ya hice andar el sonido.
    tenia que darle permisos de ejecucion a /etc/modprobe.d/sound, tal como dice el amigo fenrismx en su blog, pero ANTES de compilar el driver. lo hice asi y salio andando de maravillas. saludos desde argentina.
    Sebastian
    PS: estoy navegando de maravillas con el driver del amigo J. Cuervo!!
    que cosa maravillosa es la comunidad free soft+open source (incluyamos a los BSDs y otros, no?

  3. 3 jstitch abril 16, 2008 en 22:13

    que tal!
    oye felicidades por lograrlo 😉 lei tu comentario esta mañana y estaba por contestarte cuando me encuentro con la grata sorpresa de que todo se resolvio. Si, olvide mencionar algunos detalles como los permisos de ejecucion 😛 pero bueno, una buena actitud de investigador te permitió lograrlo 😉

    saludos y estamos en contacto!

  4. 4 Carlos mayo 29, 2008 en 18:52

    Hola jstich. En primer lugar gracias por esta info, me fue de gran utilidad. El unico problema que sigo teniendo es con mi placa de video. Cuando intento instalarla siguiendo las instrucciones de la wiki de opensuse, veo que entre los prerequisitos existe el paquete compat-32bit, pero no puedo encontrarlo con el Yast. Tambien lo he estado buscando en internet pero sin suerte. Como te habras dado cuenta no tengo mucha experiencia en linux, por lo que es probable que este haciendo una pregunta muy básica, pero preguntando es la unica forma de aprender.

    Muchas gracias.

  5. 5 jstitch mayo 30, 2008 en 9:09

    Mmm tienes OpenSuse 10.3? Tu tarjeta de video es una ATI?
    el caso es que estoy viendo ahorita justamente mi repositorio de archivos en YAST, y si tengo el compat-32 bit, instalado y todo, y lo saque del repositorio de opensuse 10.3, o sea segun yo no deberia haber pierde… Ya le diste Search? pon solamente ‘compat’ y a ver si asi aparece…

  6. 6 carlos mayo 30, 2008 en 21:42

    Hey jstitch:
    En realidad no di mucha importancia a los paquetes que faltaban en openSuse 10.3 y segui adelante, y por suerte todo salio de maravillas!!! Es cierto, cuando quieres ingresar a la configuracion de x11 te aparece un cuadro de dialogo diciendo que el 3d no esta habilitado, pero en realidad funciona. Tengo el compiz habilitado con la mayoria de las opciones y no tengo problemas, asi que no di importancia a tal dialogo y todo bien. En definitiva, si alguien tiene una toshiba A215-s7437, sigan las instrucciones de este thread que seguro consiguen hechar a andar su laptop sin problemas.

    Gracias a todos desde Argentina!!!

  7. 7 joni noviembre 25, 2008 en 18:09

    Hola! veran siento molestar, pero instale el open suse 10.3 por que me podri de windows que es una m*****, bueno la cosa esta en que tengo una placa de video ATI AGP 9200 SE, y al iniciar open, carga todo bien el bios y parte del sistema, pero cuando esta por entrar al escritorio la pantallase pone negra y se abre la consola, Y NO SE QUE HACER. AYUDA!!! POR FAVOR!!!!

    ESTE ES MI EMAIL: joni_asm_08@yahoo.com.mx
    Le agradeceria muchoque me pasen la info por un mensaje.

  8. 8 jstitch noviembre 25, 2008 en 21:37

    ah mira, me paso lo mismo a mi en algun momento! y siendo tan inexperto y sin afan de investigar en ese momento, reinstale todo y con eso quedo 😛
    obviamente no es la respuesta correcta.

    Si no me equivoco, debes reiniciar la configuracion de tu sistema X Window, lo cual se logra con sax2 -r, o en todo caso sax2 -a autoconfigura y tal vez eso ayude…

    saludos!


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




All we need to do, is make sure we keep talking… (Pink Floyd)

marzo 2008
D L M X J V S
« Feb   Dic »
 1
2345678
9101112131415
16171819202122
23242526272829
3031  

Blog Stats

  • 14,309 hits

Actualizaciones de Twitter

  • RT @SismologicoMX: Preliminar: SISMO Magnitud 6.4 Loc.12 km al NORTE de CD IXTEPEC, OAX 23/09/17 07:53:03 Lat 16.67 Lon -95.09 Prof 10 50 minutes ago
  • RT @pxcox96: Amigos, de verdad que se necesita la ayuda en Jantetelco. No hay albergues y se cayeron 52 casas acá!! Por favor difundir, ami… 1 hour ago
  • RT @baemroer: Doctores Marta y carlos necesitan relevos a las 8 PM el albergue torre fuerte en dr. Navarro 910 17 hours ago

A %d blogueros les gusta esto: